0 users online. Create an account or sign in to join them.Users

Announcement

Symphony's issue tracker has been moved to Github.

Issues are displayed here for reference only and cannot be created or edited.

Browse

Closed#260: Author details not being output in XML

I’ve used the Author field type in my section, but the detals aren’t output. I am getting the structure for the node, but no actual details…

I cannot reproduce this. What version are you using?

Note that if you added the author field after having created entries, you’d need to re-save those entries.

I’m using the latest downoad from the downloads section, 2.0.7.

Also, if it helps, I’m using the standard installation of MAMP Pro on a MacBook.

I’ll try a reinstall to see if it fixes it….

I’m using the latest downoad from the downloads section, 2.0.7.

Also, if it helps, I’m using the standard installation of MAMP Pro on a MacBook.

I’ll try a reinstall to see if it fixes it….

I’ve reinstalled it and it’s still not outputting anything in the author nodes.

Fixed. The author field was creating a new Author object, by passing it incorrect arguments. This commit should fix it: http://github.com/symphony/symphony-2/commit/5f970ddedb98d277860957e2ff6f995c1af814aa

But I don’t use subversion or git or anything. How can I fix this on my installation?

Ah, ok, I just read the code. I will manually edit the respective file when I get home.

Thank you!

This issue is closed.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details