0 users online. Create an account or sign in to join them.Users

Search

Hi All,

Just upgraded a site to 2.3.2 in localhost and JIT seems to have stopped working. All my image files are still available by directly entering their URLs but when I try to use JIT they're not being generated.

If I try the JIT URL in FF I just get a blank white screen, looking for the images in the site in Firebug "Failed to load given URL".

The non-upgraded site shows the image when I do this.

I'm not sure what's up with it but I assume JIT just isn't doing its thing.

I also tried re-saving an entry with an image in it but that doesn't seem to help.

This was an upgrade from 2.3.1 to 2.3.2 using the symphony installer/update option in the backend. I only just tried it but everything else in the site seems to be fine.

Has anyone any idea what's happened?

All the best,

-andy

Have also noticed problems with JIT in the latest release. The JIT-redirect was missing from the .htaccess-file. Try uninstalling and reinstalling the JIT-extension. That readded the missing parts and solved the problem for me.

Thanks for posting but that doesn't seem to have fixed it for me, there's already a JIT rewrite in the htaccess. I'll try re-installing JIT from the slightly newer version that seems to be on Git.

My current rewrite looks like this:

### IMAGE RULES
RewriteRule ^image/(.+.(jpg|gif|jpeg|png|bmp))$ extensions/jit_image_manipulation/lib/image.php?param=$1 [L,NC]

I updated JIT to 1.18 master from Git.

What I have found is that the 2.3.2 installer that I grabbed from the downloads page of this site seems to have an empty folder for the JIT extension so when I thought I was replacing files and overwriting my old JIT extension to upgrade to 2.3.2 I must have been keeping my old JIT which I guess was not 2.3.2 compatible.

I'll just download the installer again to double-check that's the case.

Yeah, the folder

symphony-2-2.3.2extensionsjitimagemanipulation

Of the current 2.3.2 install from the downloads page is empty.

Good grief, I mean symphony-2-2.3.2 - slash - extensions -slash - jitimagemanipulation

Can't seem to enter the slashes here...

Thanks for posting but that doesn't seem to have fixed it for me, there's already a JIT rewrite in the htaccess.

Maybe I just messed something up with my local setup then. Wasn't sure, that's why I didn't report it as an issue yet.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details