1 users online. Create an account or sign in to join them.Users

Search

I'm not sure how to troubleshoot this issue where I have installed Symphony 2.3.3 on a Mac OS X Server using Advanced Server Administration on Mountain Lion. Symphony installed with no issues, but I cannot log in.

  • Symphony 2.3.3
  • Mac OS X 10.8.4
  • Apache 2.2.22
  • PHP 5.3.15
  • MySQL 5.5.28

When I do try logging in, I can see the sessions being created, but there's something strange about the session ID values. On my localhost, the session IDs are 26 characters. On the Mac OS X Server, the session IDs are maxing out the 100 character limit. So, I have a feeling that the problem has to do with how the session IDs are being created.

What would be the best way to debug where the sessions are going wrong?

A quick fix to try would be to increase the varchar length in the database to something like 300 and see if that fixes it.

Other than that, I could take a look at your PHP config file to see what is happening there, if you like?

It may be that you have the hardened or suhosin PHP modules enabled which add more entropy to the session length. Try John's suggestion of bumping this column length up

Suhosin will just encrypt session data, not the session ID.

John's suggestion to increase the varchar length of the session field to 300 fixed the issue. Thanks!

I would like to know which specialty is causing these long session IDs.

Does anybody know?

Suhosin, probably:

  • http://www.hardened-php.net/suhosin/configuration.html#suhosin.session.encrypt
  • http://www.php.net/manual/en/function.session-id.php#73746

I believe Brendan is correct. Since I have access to the server only when I am on campus, I only had time to test the fix yesterday while connected to the LAN. But according to this article and Wikipedia, Suhosin is activated by default on Mac OS X Server as of version 10.7.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details