0 users online. Create an account or sign in to join them.Users

Search

After a server-update from our provider I get the following error. I’m clueless what to do … can anyone assist?

Fatal error: Declaration of CacheDatabase::delete() must be compatible with that of iCache::delete() in /…/symphony/lib/toolkit/cache/cache.database.php on line 20

Looks like PHP ist 5.2.6 is running … might be the problem.

It may also be strict standards, ensure that E_STRICT errors are suppressed.

That's odd that the provider has updated the server but it's still on PHP 5.2!

Thanks Brendo. It really was the provider moving their server to new hardware. They said all software should have been copied 1:1, but for some strange reason PHP switched back to 5.2.6 … odd. But solved :)

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details