0 users online. Create an account or sign in to join them.Users

Search

Symphony 2.6.7 is out — the latest and greatest!

Thumbs up!

Michael, just wondering, is Symphony compatible with the newer versions of PHP (7+)?

Not yet. I think it’s due for 2.7.x.

Yep, @nitriques is working on it.

Indeed!

@nitriques PHP7 will probably break a lot of extensions too?

PHP 7 will probably break a lot of extensions too?

If so, 2.7.x should probably be skipped and named 3.0.0 directly.

Everything else would just lead to chaos. Extensions would be compatible with 2.7.x in theory (because 2.7.x isn't allowed to have breaking changes), but wouldn't be compatible with the same PHP versions as the core.

Right now, PHP7 does not seems to be a big problem, but test are being made. PHP5.6 is still supported and that's what we aim to do. But I'd like to make the core 2.7.0 runnable on 7 if possible.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details