0 users online. Create an account or sign in to join them.Users

Search

Hey everyone,

I just installed a clean 2.7 and I'm able to install and login to the backend but then I'm getting this PHP error on the frontend:

Fatal error: Can't use method return value in write context in /home1/jordgar/public_html/toolkit/symphony/lib/toolkit/class.sectionmanager.php on line 194

and then in the backend (after logging in):

Parse error: syntax error, unexpected ')', expecting :: (T_PAAMAYIM_NEKUDOTAYIM) in /home1/jordgar/public_html/toolkit/symphony/lib/toolkit/class.administrationpage.php on line 475

You can have a look at phpinfo() here: http://toolkit.voluntarysectorarchives.org.uk/phpinfo.php

The server seems to fill all requirements.. Any clues?

Thanks in advance!

As a bit of extra info. The lines above are the following:

if (!empty($obj->get('modification_date')))

and

if (empty(__SYM_DATE_FORMAT__))

respectively.

On http://php.net/manual/en/function.empty.php I can see this:

Note: Prior to PHP 5.5, empty() only supports variables; anything else will result in a parse error. In other words, the following will not work: empty(trim($name)). Instead, use trim($name) == false.

Which would then make sense why I'm getting the first error (perhaps not the second) because the server I'm using is running 5.4.45.

Would that mean that Symphony 2.7 changes the server requirements from PHP 5.3 to 5.5?

So I've changed a couple of lines where we have stuff like if(!empty(...)) to if(!(...)) and now symphony seems to be running on PHP 5.4 however I wonder if I'll find other situations where I can't easily fix something? Should the Server Requirements be updated or shall we propose some changes to make Symph 2.7 still compatible with PHP 5.3?

It might be that PHP 5.3 is off the list for Symphony 2.7+. I have asked Nicolas if he can confirm. In case it is the requirements of course need to be updated.

Would that mean that Symphony 2.7 changes the server requirements from PHP 5.3 to 5.5?

If that would be the case, it would be a bug and would be addressed in one of the next patch releases (2.7.x), as 2.7 isn't supposed to break backwards compatibility, which includes server requirements.

Can you please create an issue on our GitHub repository?

Hi guys! Yes 5.3 is still supported (sadly)

I'll fix this ASAP ! Thanks !

@pauloricca As reported on github, this commit should fix the PHP 5.3 and 5.4 issues.

Thanks for playing.

Amazing! thank you :D

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details