1 users online. Create an account or sign in to join them.Users

Search

Hi,

I am using this rather old extension in some of my sites.

It still works with the latest version of Symphony (2.7.7) even though it hasn't been maintained for years.

Unfortunately, it breaks when I upgrade my server to PHP 7.

What steps must be taken to upgrade this extension to work with PHP 7?

I've never developed any extension myself, that's why I'm asking.

Thanks for any pointers.

I just had a look at it and there are not the usual PHP7-problems. You should ping Nils Werner about this. The problem might be not related to PHP7 at allm theres an open issue about it not working at all from January 2016. And there Nils states:

I haven't used Symphony in over 3 years, so I have no idea where to start debugging the issues you are mentioning.

:/

Apparently phpsass is not maintained anymore. Might be worth to have a look at the forks.

Hi & thanks for your help.

You're probably right here. I had a whole bunch of problems with PHP 7 and most of them were solved by this issue.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details