1 users online. Create an account or sign in to join them.Users

Search

Just installed Symphony in local mac OSX 10.5.7 environment, using MAMP, and everything seems fine, I log in and get front page, but have no idea how to get to backend admin. I see Symphony default theme spectrum, so everything seems fine. Am I stupidly missing something obvious, or did something go wrong.

Never mind. Trashed MAMP and preferences, tried it again, and everything is fine.

Funny, I got exactly the same issue. I get to the admin login but it does not redirect me after I’ve entered my credentials.

Same OS X version, latest MAMP and tried both 2.0.3 and 2.0.4.

What did you do exaclty to get it working (I have tried to trash MAMP and “reinstall” it)?

@pertoyra: did you install a new copy or did you upgrade?

If you upgraded, did you make sure to backup your .htaccess in your symphony/ folder as per the instructions in the README?

The other possible explanation is that the Symphony isn’t able to correctly access your database. Check the file under /manifest/logs/main and post it on pastie

@Allen: Made a fresh install, tried both from git and installation package.

And yes, I followed your README. I’ve never had any problems installing before and it works just fine on my hosted service so I guess MAMP is the problem.

Regarding the database access; the tables are filled with the default workspace data and the /manifest/logs/main is empty (except from timestamp). When entering the correct credentials the login page returns nothing, when entering wrong password (or username) I get an error message so it has to have DB access, no?

Hmm, looks like you’ve done all the right things. No errors logged and DB connectivity seems fine also. It’s difficult to know exactly what is going on without knowing more about your environment.

I fully understand, don’t know what else to tell you. Freshly installed OS X 10.5.7 with MAMP installed under /Applications and Symphony under ~/Sites/symphony-2. The OS user account I’m using is a regular user and not an administrator, I’ll try everything as administrator later today if that could be a problem.

Apache and MySQL logs are also error free. I doubt that Symphony is the issue here, but since there might be a lot of ppl who want to try Symphony out and MAMP is an easy way to do so this might be worth solving. I’ll let you know of my progress.

I also use MAMP for local development and haven’t had any issues. Quite bizarre.

I hit issues with MAMP a couple of point releases ago, but interestingly they were only happening with Firefox. It seemed to be a problem of Firefox not correctly sending/receiving headers, not starting the PHP session. Using Safari did work, and the bug was quickly resolved. Although it sounds like a server-side issue, have you tried in alternative browsers?

have you tried in alternative browsers?

Yes. Only Opera works for me. Safari 4.0.2 same as Firefox 3.5: no login!

I’ve just tried 2.0.4 with Firefox, Safari, Chromium and Opera 10. Opera is the only one that works!

Seems like we have a bug somewhere…

Not just me then, and since I don’t have Opera installed I never solved it. Don’t you think this could turn out to be quite a showstopper for new users wanting to try Symphony out.

But how come it’s working for some ppl?

EDIT: Downloaded Opera 10 Beta when I got home and just like to confirm: it works just like it should!

Bizarre indeed. Everything works perfectly for us on every browser.

Just so we’re clear – everyone who’s having issues are all on MAMP?

We really need to be able to reproduce this to troubleshoot..

MAMP 1.7.2 running:

  • PHP 5.2.6 (would you like to have the phpinfo()?)
  • MySQL 5.0.41

Just made a fresh install on my web host (binero.se) and it works just fine, they’re running (on RedHat):

  • PHP 5.2.9
  • MySQL 5.0.67

Seems like Symphony works better ‘down under’? ;)

I just updated from 2.0.3 to 2.0.4 - following the instructions. I am on Media Temple by the way.

I login to my Symphony Admin and it redirects me to a 404 page.

Anyone got any ideas why this is happening?

@pertoyra: I’m running MAMP 1.7.1. I shall try 1.7.2 at some point to see if it causes the problem. If you manage to get time before I do, try 1.7.1 and see if it fixes things. If so, it could be a MAMP issue.

@nicktoye: sounds like you didn’t back up your htaccess file: /symphony/.htaccess. Did you follow the README instructions?

Yes I did back it up. Honestly. What else can I do? Can I rollback?

No, you cannot roll back. When you replace your symphony folder, that contains all the 2.0.4 updates.

What is in the content of your /symphony/.htaccess file? Post it up here.

 ### Symphony 2.0 - Do not edit ###

 <IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /igaragelocator/

### DO NOT APPLY RULES WHEN REQUESTING "favicon.ico"
RewriteCond %{REQUEST_FILENAME} favicon.ico [NC]
RewriteRule .* - [S=14] 

### IMAGE RULES 
RewriteRule ^image/(.+.(jpg|gif|jpeg|png|bmp))$ /igaragelocator/extensions/jit_image_manipulation/lib/image.php?param=$1 [L,NC]

### CHECK FOR TRAILING SLASH - Will ignore files
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} !/igaragelocator$
RewriteCond %{REQUEST_URI} !(.*)/$
RewriteRule ^(.*)$ /igaragelocator/$1/ [L,R=301]

### MAIN REWRITE - This will ignore directories
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ /igaragelocator/index.php?page=$1&%{QUERY_STRING}  [L]

 </IfModule>

 DirectoryIndex index.php

 <IfModule mod_autoindex.c>
  IndexIgnore *
 </IfModule>

 ######     

I reckon it must have something to do with Permissions as there is nothing in that file I can see that obviously points to something.

I had a backup fortunately. So I managed to resolve it. I reckon I may well have backed up the wrong .htaccess, Shiraz has taken control.

Yeah, that’s the wrong .htaccess

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details