0 users online. Create an account or sign in to join them.Users

Search

I’m getting complaints from a client that some specific product entries are sometimes not appearing. I use a data source with dynamic sorting to display all products in a certain category. I can confirm that some entries are sometimes not displayed, while sometimes they are, without any apparent changes to the system. It appears to only affect products from one category, and only specific entries. However, I cannot reproduce this when I want to which makes debugging all the more difficult.

Perhaps anyone can shed some light on this from an angle which will give me new ideas on how to fix this problem?

You’ve probably checked this, but have you looked at the DS sorting option? Is it set to random?

Hmm I think I’ve had this before. Make sure that System ID is the sort field.

With this data source I can specify myself how I want to sort, but descending is default.

It appears there indeed is some trouble with sorting by ID, somewhere it says id instead of system:id. I hope this fixes the problem, thanks for the suggestion guys!

Any ideas why some posts are hidden while others are shown though?

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details