A new ensemble, “Frontend Members Reference” is now available for download. Comments and feedback can be left here but if you discover any issues, please post it on the issue tracker.

Frontend Members Reference updated to version 1.0.1 on 15th of February 2010

sending emails not working. Errors from my log:

2010/02/16 19:51:03 > UNKNOWN: 8192 - Assigning the return value of new by reference is deprecated in file /Users/icek/Sites/symphony-members-reference-ensemble/extensions/members/extension.driver.php on line 1087

I don’t understand the activation process. I’m registering then email is send to me with activation link. Clicking on it moves me to forbidden area, so I need to login first, and then go back to my email and click link again. Isn’t that too complicated? I think that my users do not understand this procedure.

I modified extension.driver.php function:

public function processEventData($context){
    if($context['event']->getSource() == self::memberSectionID() && isset($_POST['action']['members-register'])){
        $fields = $context['fields'];
        $member_field_handle = $this->usernameAndPasswordFieldHandle();
        $this->login($fields[$member_field_handle]['username'], $fields[$member_field_handle]['password']);
        return $this->__sendNewRegistrationEmail($context['entry'], $context['fields']);    

Now users after successful registration are automatically logged in. To prevent robots I use captcha extension.

Hey guys, I’m having trouble installing this Ensemble on my shared web host. Has anyone else had any luck? I’ve installed Symphony a ton on this web host, I’ve been able to get 2.0.7 RC2 up and running, and I’ve even been able to add in the members/asdc/smtp extensions onto that and everything seems to be working. But I can’t get this ensemble working for the life of me! (I’ve tried 3 different ways now)

On the surface, it seems like some kind of .htaccess problem because I’m installing it in a folder, and when I browse to that folder it redirects to the 404 error of my root directory (A Wordpress installation, I know, I know…) But even after I got the working installation of 2.0.7 with membership added, I dragged that .htaccess into the folder with the ensemble (yes, I changed the RewriteBase line) and I still had no luck.

Any other suggestions? Is there something that might need to be fixed?

Is this ensemble going to be updated to Symphony 2.07 final?

After installing, I get the following error. I also posted this in the issue tracker for this ensemble.

ini_set() [function.ini-set]: A session is active. You cannot change the session module's ini settings at this time.
/home/myname/public_html/candidates/public/symphony/lib/core/class.session.php line 29

24              if (self::$_cache->check('_session_config') === false) {
25                  self::createTable();
26                  self::$_cache->write('_session_config', true);
27              }
29              ini_set('session.save_handler', 'user');
30              ini_set('session.gc_maxlifetime', $lifetime);
32              session_set_save_handler(
33                  array('Session', 'open'),

This ensemble is using Symphony 2.07 RC2. I tried upgrading (to Symphony 2.07 final) by replacing the symphony folder and the index.php file… but I still get the same error. I’ve RESET my browser and still get the same thing.

Does anybody know how to fix this?

Try emptying the sessions table in your DB?

I did. It was a new install. It was empty. I even tried to empty the cache table as well. That didn’t work either.

Actually, I just tried to do a basic install of Symphony 2.07 final, and got the same error. Installed via git on the master branch of Symphony 2.07 final, git://

Can you explain me how reset password works? I’m getting new e-mail with reset code. Password then should be reseted and I can login with new credentials. But I don’t have any my new credentials…


Ok, new password is send by e-mail.

I updated this ensemble to 2.0.8RC1 and encountered this issue.

Installing this ensemble from scratch (so the original ensemble with 2.0.7RC2 in a PHP5.3 environment, I ran into the following error after install…

Warning: date() []: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST'.

I ran a Google search for this error and ran across the same issue for Wordpress users. I added the following code to my manifest/config.php file (at the top of the file)…


That seemed to squash that bug temporarily. Where is the config file created during the install process? Is there a way that we can force it to use the date_default_timezone_set function so we don’t run into this error while installing?

EDIT: In the symphony/lib/core/class.datetimeobj.php file it uses date_default_timezone_set function. So why is this error keep popping up?

OK. Anytime, I make any preference changes that updates the manifest/config.php file, it gives me the error above. It looks like it’s not setting the date_default_timezone_set() with this array in the manifest/config.php file…

###### REGION ######
        'region' => array(
            'time_format' => 'g:i a',
            'date_format' => 'd F Y',
            'timezone' => 'America/Chicago',

So, what core symphony file reads the config.php file?

I tried czheng’s fix here, and it doesn’t fix this problem.

I’ve only noticed this on php 5.3. I don’t recall running across these date and time errors with php 5.2.

Looks like the date_default_timezone_set() is dealt with in Alistair’s fix located here.

sending emails not working. Errors from my log:

2010/02/16 19:51:03 > UNKNOWN: 8192 - Assigning the return value of new by reference is deprecated in file /Users/icek/Sites/symphony-members-reference-ensemble/extensions/members/extension.driver.php on line 1087

icek, did you ever figure out how to get the emails working?

Have a look here.

mail branch of bauhouse’s members contains the fix, may be it’s simpler to just download it instead.

Thanks for the quick answer. I made the fix and it seems to be working just fine.

I’m not an expert but according to my XAMPP installation, I think this ensemble may be susceptible to sql injection.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details