Hi guys, I followed the installation instructions including setting the permissions yet I can gain access to all the folders eg .

  • Parent Directory
    • css/
    • data-sources/
    • events/
    • images/
    • pages/
    • utilities/

Is this normal for an installation? Does my .htaccess in the root need adjusting? Or have I missed a step during installation? thanks

ok I’ve just found this from here

Make sure when you’re installing to set the file permissions to 0644 (or 0664 if you need group write). There is nothing you’re uploading to a Symphony install that should require execute bits to be set (0755/0775).

Actually, after all the hoo-ha about the hacks late last year, why does the default installer still try to set the execute bit on files? Baaaaad…

For the beginners out there, I’ve added the following to .htaccess in root.

    Options All -Indexes

RewriteEngine on
RewriteBase /

Order Deny,allow
    allow from ***.***.***.***
    Deny from all 

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details