Is it just me, or is Markdown Extra not working.

None of these work, they just show up as text. I have tried on multiple installations with no avail.

I have a field set with ‘Markdown Extra (with Smartypants)’ as the text formatter.

No idea what to do. Any advice?

Sounds like the bug Markdown Extra does not work (with fix).

Just checking that you are using ‘copy-of’ rather than ‘value-of’ in your template. value-of only returns plain text.

ie to make mark down work use:

<xsl:copy-of select="whatever"/>

rather than

<xsl:value-of select="whatever"/>

I’m guessing you already know this but just in case! You should be able to see the formatting (all the html tags) in your XML in Debug view. If they are not there then it’s probably bug above.

You’ll want to use <xsl:copy-of select="whatever/*"/> which will display everything verbatim inside of the <whatever> node.

OR for even more flexible output, you might want to try Allen’s HTML Ninja Technique.

Sorry should have been clearer. Markdown is working with no problem, but the functions available in extra (i.e. these: that are not working.

Tried the fix mentioned by klaftertief, and all is working now.

Thanks for the help everyone.

this is indeed a bug (filed by nickdunn) that’s very easy to fix and will probably be picked up before the 2.2 release.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details