I tried deleting my DNS Cache on my Mac (thanks for the idea @bzerangue) by running the following:

sudo killall -HUP mDNSResponder

I then restarted the computer.

@bzerangue referenced this article: Flush DNS cache in Lion and Mountain Lion


Did not work. And the passwords are still being rewritten by Symphony when I attempt to login.

I know we're using salt now, but this doesn't look salted though it is SHA-1 length (40 char).

In Symphony 2.3.1, they implemented Cryptography methods for improved password security.

@wjnielsen - what TYPE and LENGTH is your password field in sym_authors set to?

If your password field in the sym_authors table is still set to VARCHAR(40) and not VARCHAR(150), it looks as if the following ALTER TABLE didn't fire properly during the update…

// Increase length of password field to accomodate longer hashes

Symphony::Database()->query("ALTER TABLE `sym_authors` CHANGE `password` `password` VARCHAR( 150 ) CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL"); }

See lines 90-91 from /install/migrations/2.3.1.php file.

just encountered same issue in updating 2.3 to 2.3.1 :(

@moonoo2 - see comment #22.


Apparently, the problem was in the sym_sections table (from /manifest/logs/update):

13 January 2013 19:33 > Notice: Updater - Migration to 2.3 was unsuccessful
Could not complete upgrading. MySQL returned: 1054: MySQL Error (1054): Unknown column 'entry_order_direction' in 'field list' in query: SELECT SQL_CACHE `handle`, `entry_order`, `entry_order_direction` FROM `sym_sections`

I ran this SQL, adding the needed table columns:

ALTER TABLE `sym_sections` ADD `entry_order` INT(3);
ALTER TABLE `sym_sections` ADD `entry_order_direction` VARCHAR(4);

I then ran the update again, and voila:

13 January 2013 19:42 > Notice: Updater - Migration to 2.3 was successful
13 January 2013 19:42 > Notice: Updater - Migration to 2.3.1 was successful

Special thanks to

@bzerangue and @tonyarnold for their time and help troubleshooting this.

Please post this issue on GitHub! This must be fixed in the updater.

Thanks, Nils!

Looks like there are some errors involved there Nils - which I hadn't seen.

I just had to fix this issue on a site (only found this thread by chance - so thanks for the help everyone!) and hadn't faced any trouble. It actually sprang on me out of the blue after deploying the site and having logged in on at least a few occasions. That side of the problem may have different roots, but regardless my password field needing manually changing to varchar(150) to enable us to log in again, and there were no errors during upgrading.

UPDATE: Just realised, and posted in my thread, that I think my issue was caused from performing an offline upgrade and only dumping/importing the data from the db, not the authors (as they hadn't change) - so the authors part of the db didn't actually get updated on the live site causing the discrepancy. Doh!

@wjnielsen, what version were you updating from? Just trying to figure out why you didn't have an entry_order_direction column in the first place!

@brendo - @wjnielsen was updating from Symphony 2.2.5.

Very odd, the entry_order_direction column has existed since at least :)

how to get symphony admin panel

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details