0 users online. Create an account or sign in to join them.Users

Search

This question is primarily toward Nils but anyone can jump in.

I'm wondering whether i'm getting this wrong or not... I have a site which uses the extensions "Date and time 2.0" and "Subsection manager 1.2"

Both extensions use the Stale library and both extensions check whether they should include the library based on the existence of the class. This sounds logical but my problem lies in the fact that both extensions seem to include a different version of Stage! (according to the readme that is ...)

Is this kind of dependency smart? Isn't more checking needed? Perhaps Stage itself should be a single "extension"?

At this moment i can only get the 2 extensions to work when i place an empty class.stage.php in one of the lib folders... when i include them both completely, i get errors.

The mentioned versions of Date and Time and Subsection Manager should actually bundle the same Stage classes. If they don't this is a bug.

Is this kind of dependency smart? Isn't more checking needed? Perhaps Stage itself should be a single "extension"?

I'm aware of this problem, but I'm not sure about the best approach yet. Clever ideas are welcome.

I am quite sure that both extensions are the latest but I will tripple check tomorrow and file a bug if it is one.

I guess this sort of dependency could happen more often, this seems like something we could call " symphony core extensions".... Or classes must be namespaced by the extension ...

I suggested this to you at Symposium Nils, that the Stage be separated out into an extension of it's own, that way other developers could use it too if needed.

I don't think you got the drift of what I meant though ;o)

Well it's not as simple as it sounds. Stage is just an interface so it would be quite different from other extensions. Furthermore, creating a separate extension doesn't solve the versioning problems. In which case I have to ask: what makes it superiour to a submodule?

Well, the extension should be maintained and backwards compatible. Newer versions should not break older versions or marked as deprecated for extension builders to act upon ...

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details