Hi there,

Got a site up and running. I have a template that is used on four of the main pages of the site to show a title and an image. It uses JIT to reduce the image down to the required width.

On two of the pages JIT is working and on the other two it isn't. On the page where JIT isn't working the images are showing up fine, they are just showing up as the original size rather than the JIT specified size.

In the mark up they are appear exactly the same:

Working page inside the src attribute:

Not working page inside the src attribute:

As you can see they are not the same size despite having the same markup??

All pages use the same template and have all the same url params etc.

At the moment I've just set all images to img {width: 100%} as a temporary solution but anyone have any idea why one image would work and another wouldn't and what I might do to fix it.

All images are uploaded using the 'Unique Upload Field' extension which adds that unique string to the image filename.

I'm very confused!

Are the original images different dimensions? i.e is one page Portrait and the other landscape? Also your second link points to the first file.

Started having similar issues with latest JIT release where images above the set jit width or height are downsized, but where 1 dimension is smaller and one bigger than the JIT rules.. neither width or height is being resized.

Hey - both of the original files are exactly the same size... that's why I'm so confused! Maybe it's a bug in the release.... but pretty weird bug when in exactly the same conditions one image works and one doesn't...

@timchesney, images look the same for me.

For me both images are 620 pixels wide (while they should should be 460 pixels wide). However, when I try 459 or 461 pixels, it works. So I guess you have messed up the cache somehow. I suggest to delete the cache files and see what happens.

Thanks Michael - sorry for my ignorance but just checking that would mean deleting everything in manifest/cache - don't want to delete the wrong thing!

Yeah, you can safely delete all the files. It will just make the site a bit slower while the cache entries are being re-built. (I do this from time to time, because the cache may/will contain orphaned stuff. I never experienced any problems.)

Ok - I've deleted everything in manifest/cache but still no dice.

Just did some more testing. It seems to work fine when the width is 456 up to 458...but stops working at 459 and 460. Starts working again at 461.

Tried changing the image to a totally new image and it works fine... for both the broken images.

Really not sure what is going on there but seems like a bug to me!

stops working at 459 and 460

I can't confirm this. For me it worked with 459 pixels as well. Only 460 was wrong.

Nevertheless this is super-strange. Have you changed the .htaccess rules, maybe added some rules which don't play nice with JIT?

Both 459 and 460 work fine on my local installation with the image you've posted...

The only thing I can think of is that this site was set up using an exported ensemble... which included the images that aren't working.

I haven't changed any permission or stuff in .htaccess though.

Plus most of the images (other than two on the whole site!!) are all working perfectly.

Ah well - re-uploading fixed the issue for me so I have no idea what was going on.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details