I've got a upload field where entries are imported with the imort csv extension. But the actual images are not uploaded yet... (only the path to the workspace folder in the database). In the meantime i would like to edit my entries and keep the upload value.
But i am getting a validation error (as i should but really not handy in this case) when saving the entry:

The file uploaded is no longer available. Please check that it exists, and is readable.

See attached screenshots,

Can someone help me how to decline this message or point me to the file where the validation takes place so i can turn it off?


Schermafbeelding 2012-02-15 om 17.47.00.png

Which upload field are you using?

It's symphony's default file upload field

This validation cannot be turned off unfortunately, it's really an edge case where you want to proceed without having the file saved.

Hi Brendo,
Are you sure there's no hack around this?
I would come really in handy for now...

You could temporarily disable the check for the existence of uploaded files by commenting lines 255-258 in field.upload.php. Though I don't take any responsibilities for any sideeffects.

@ klaftertief
I tried that already, but it only disables the errormessage... The record still doesn't get saved.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details