0 users online. Create an account or sign in to join them.Users

Author:
Nitriques
Version:
1.0.0
Released:
15 May 2015
Category:
Field Types, Multilingual, and Third Party Integration

Description

Field: Multilingual oEmbed

Version: 1.0.x

A multilingual version of the oembed_field extension

@see http://oembed.com

SPECS

REQUIREMENTS

INSTALLATION

  • git clone / download and unpack the tarball file
  • (re)Name the folder multilingualoembedfield
  • Put into the extension directory
  • Enable/install just like any other extension

See http://getsymphony.com/learn/tasks/view/install-an-extension/

HOW TO USE

  • Make sure that all requirements are met.
  • After installation, add a Multilingual oEmbed field to a section
  • Configure the field
    • Select at least one supported driver
    • You can add extra parameters to the oEmbed request's query string: this is usefull for settings embed sizes
  • All the data will be available as xml in a datasource
  • Use the oembed tag for embeding the resource into your frontend

Non-native

"Non-native" solutions like embed.ly are tested after all other "native" solutions. This will allow you to enable both natives solution while being able to revert to a global fallback. If other non-native solutions are added, please do not enable more than one because this may cause un-wanted behavior.

LICENSE

MIT

Made with love in Montréal by Deux Huit Huit

Copyright (c) 2015

See: http://symphonyextensions.com/extensions/multilingualoembedfield/

Repository

https://github.com/DeuxHuitHuit/multilingual_oembed_field

Discuss this Extension

Compatibility

2.7.10 Unsure
2.7.9 Unsure
2.7.8 Unsure
2.7.7 Unsure
2.7.6 Unsure
2.7.5 Unsure
2.7.4 Unsure
2.7.3 Unsure
2.7.2 Unsure
2.7.1 Unsure
2.7.0 Unsure
2.6.11 Unsure
2.6.10 Unsure
2.6.9 Unsure
2.6.8 Unsure
2.6.7 Unsure
2.6.6 Unsure
2.6.5 Unsure
2.6.4 Unsure
2.5.4 Unsure

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details