For some reason I cannot upload large files. I have increased the maximum allowed upload size in the config file. I have also increased the local server allowed upload size. But still no success. Any ideas?


To stat narrowing down the problem: does the number appearing in /data/params/upload-limit in the param pool of debug devkit corresponds to the one you changed in the config file?

No it doesn't

Could it be because of the cache?

I have also increased the local server allowed upload size.

If I remember correctly, there are two or three different PHP config settings to do with upload/POST max sizes. Which ones have you set so far?

Ok, according to my (not so deep) experience, that should mean the max_upload_size you set on the config.php is overridden by another value—I guess the one of your local server (which is kind of weird if you changed it as well): are you using MAMP?

Max Upload Size in the config.php

and uploadmaxfilesize in php.ihi

Try post_max_size, too.

Thanks David. That's what it was.

Bit of advice from experience...

Always set the post_max_size to at least 2mb more than the upload_max_filesize. Weird things can happen if not, especially when the file exceeds the size limit. If both are the same, the entire post can be dropped without an explanation.

It's a weird PHP flaw IMO.

Thank you for letting me know.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details