Ever since I attempted to install the ElasticSearch extension I seem to be getting this error often. I'm not sure if it's related to ElasticSearch but that was the time when it started to come up.

Warning: chmod(): Operation not permitted in /Library/WebServer/Documents/diplostar/symphony/lib/toolkit/class.general.php on line 861

I'm using PHP 5.5

Found a note here:

Note: When safe mode is enabled, PHP checks whether the files or directories you are about to operate on have the same UID (owner) as the script that is being executed. In addition, you cannot set the SUID, SGID and sticky bits.

maybe that is it.

I am getting the same error message all the sudden on my local development environment. I even set everything 777 in local directory to see if this would fix it, and it doesn't.

Any thoughts???

OK. I think I found it... It was the ownership permissions on the cache files. Needed to be set to the server user/group account instead of my own user account. So on my Mac it was user: _www and group: _www

Thank you guys. I've had to play with ownership privileges on files and directories until I've found the right setting. It's working now.

Hi. I'm still getting the error mentioned above and I can't figure out what's wrong. Could anyone please give me some help. I'm attaching the main log file.

Many thanks.


your apache log would be nice too, and if it possible. the ownership of your files and folders and the uid, your php is running on.

I'm using Mac OS X 10.8.5

The account I'm running from is ovimacbook which comes also as the owner of the files and folders and the user under which php is running.

I've attached my Apache error_log file.


I'm quite not sure, that apache and php running as this uid.

but your error.log isn't attached as far as I can see.

Sorry, here is error_log file


the last log entry semms to be an issue whole installing contenttypemapping. writing to config.php seems not to work.

this point of an permission problem, as mentioned before by bzerangue.

when you fix ownership this other issues might be solved.

Thank you @moma. It looks like there needs to be a combination of ownership settings which before I didn't seem to need. Before I was making the root directory 777 and all files 666. Now it doesn't seem to like the symphony folder as 777 but rather 755.

I' dont know, why 0777 don't works. I'd never has this trouble.

But now all is fixed? In the other case please post more infos like:

ps aux | grep apache 
find /var/www/htdocs/symphony/ -exec ls -al {}  ; | sed -e '/www-data/d '

when this is empty this is not as bad. my apache user is www-data my swymphony root folder is /var/www/htdocs/symphony/.

Had the same problem, was because php upload limit was to small..

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details