I've got a problem to get dynamic.json-datasource and - hopefully - found the reason in getway:

the page answered - something like:

400 Bad Request: Your Browser send a request the server could not understand Reason: You are speaking plain http to an ssl-enabled server port Instead use the https-scheme to access this url please

Found nothing like a ssl handschake in class getway. made I something wrong, should this be improved, should I try to write something?

remarks welcome

Can you confirm the URL in your data source is https?

yes. definite. It's the other onlineshop I should implement:

may I've done something wrong? I can send you my api key, for test purposes, if ness.

sorry, was my fault :( curl was not installed on the server:-( the Getway fallback don't know nothing about ssl. no warning was given, that some kind on fallback was used.

so maybe write a log entry at: // No CURL is available, use attempt to use normal sockets

about line 360 ?

I realized that curl with ssl has verify cert disabled allways. this seems to be not best best practise. Is there any possibility to triger the certcheck on/off at each datasource?

getway() seems to get all infos needed via parse_url. that's as elegant as limited. I really don't know enough about php and the symphony core to managed this.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details