Hi guys,

I'm pretty sure this is a server issue, but wanted to share the situation in case anyone had experienced something similar.

I've just deployed a site onto a clients server and attempting to access anything off the root is generating a 404.

This includes static files.

http://domain.tld resolves fine.

http://domain.tld/about/ 404's.

http://domain.tld/workspace/uploads/background.jpg 404's.

PHP 5.4, mod_rewrite is enabled. I've updated the rewrite base in the .htaccess (simply set to '/').

Not really sure what else to try to be honest (we're not server people)! It's not an issue we've come across before, hence why I'm pretty sure it's a server setup issue.

Any ideas much appreciated!


How about with www. prefix? Not always both set up for DNS.

Try removing the symlinks line in htaccess that I have to do on one client's hosting.

Sometimes having to remove something from here:


Does http://domain.tld/workspace/uploads/background.jpg resolve with no htaccess? I mean without Symphony having any chance to join in.

@munki Good tips - will report back!

@munki Turns out the http://domain.tld/workspace/uploads/background.jpg example was a red herring, as the file it was referencing actually wasn't there (uploads is empty because this was a fresh deployment from the repo). So actually I'm more convinced that it's a mod_rewrite issue.

Incidentally it can't be the www. thing (although good suggestion) as I'm actually using an IP address.

Would have been a better example.

Hm after some further testing I think there's something wrong with mod_rewrite on their server. I found some basic test on the net and using that it flags mod_rewrite as being on, but I can't actually seem to get any rewrite conditions to work.

Not by accident an IIS server? Or your htaccess is ignored/not enabled?

Not by accident an IIS server?

Nah, that's the trick they tried on us the first time around! :)

Got to the bottom of it in the end, needed to change the following in the apache config:

AllowOverride None to AllowOverride All

Along with a rebuild of Apache. I'm not totally clear if the above fixed it, or rebuilding the server - but either way it works now :)


AllowOverride All is like enabling htaccess ;-) Happy to hear that it's solved.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details