This is strange: the index did exist, but the symphony_fulltext analyser did not. After renaming the index the analyser is detected, and working! Can't wait to roll this into my next project, thanks!

Good stuff. I think I know what's causing this so will look into it this week.

When I toggle build-entry-xml from 'no' to 'yes', viewing my search results page throws the error:

PHP Fatal error: Class 'extension_subsectionmanager' not found in /var/www/symphony/extensions/subsectionmanager/fields/field.subsectionmanager.php on line 680

I'm not quite sure how to begin troubleshooting this error - any suggestions?

I originally tried to get the result entries into the page XML using data source chaining, but didn't get the entry's XML - probably didn't set it up correctly. I'll go back to troubleshooting that method, but am curious as to why I'm getting this error. It seems like enabling build-entry-xml is easiest way to get result entries included in the page XML.

OK, got data source chaining working on my search results page - so I'm less interested in build-entry-xml feature. But I'm a bit worried there might be something wonky w/ my subsection manager installation.

Today I discovered Bonsai which will eventually be a hosted ElasticSearch provider. You can currently use their free beta through Heroku (which I am testing at the moment). I'll keep my eye on their progress. I don't know what pricing will be, but it would take away the responsibility of managing your own ES server.

I'm not quite sure how to begin troubleshooting this error - any suggestions?

Hmm not quite sure. It could be that the SSM field is doing clever things. Or it could be that the ES extension is not initialising the fields properly. My hunch is that it's the latter, so I'll make a point of testing this before the next release of the extension. Sorry 'bout that. Glad you got chaining working.

If you have any feedback, please let me know. How are you finding it?

It's working like a charm. Thanks so much for developing this, it came along at exactly at the time I was looking for a search option for our site. I'll post any further feedback I have as I tweak the way it works with our site and sections.

Glad to hear it's working for you, and looking forward to your feedback.

At the Cologne Symposium last year I gave a demo of a search ensemble which indexed a whole stash of Shakespeare's plays. I've finally ported this to use ElasticSearch, so I give to you: Surfin Shakespeare. It's a small demo of the basics of using ElasticSearch:

  • mapping basic text fields
  • indexing large numbers of entries (~32,000)
  • "site search" results pages, searching multiple sections at once
  • autosuggest

Surfin' Shakespeare

I will try the demo as soon as possible. Thanks a lot for sharing this!

Nick, I will be implementing this in the large project I have been working on for the past few months. I am really, really excited to show you all the final results, but for now: thanks so much for this great extension.

We are moving from google search because we needed more control, and I could not have hoped to find something so powerful, yet so simple and straightforward to setup.

Great! Can't wait to see it.

hi Nick
i try to implement ES but always gave me this error when i submit a section for mapping :

TypeMissingException[[almedys-life] type[pages] missing]

ps : the index exist en ES

Any ideas are welcome!

Thank's for your help.

Update: I think I've found the issue - on line 24 of content.mappings.php (elasticsearch/content/) there is a call to:


It seems to be throwing an exception because the type/index doesn't yet exist...

Hi Nick, I'm having the same issue as valactive... Trying to get this implemented for a current Symphony 2.3 project and having no joy when trying to submit sections for mapping..

Also I'm experiencing odd behaviour when attempting to map sections with spaces in their names (e.g. "Page Content"). In order for them to appear in the mappings page I have to name the files with underscores (e.g. "page_content.json", "page_content.php"), but when the .json file is referenced in the table on-screen it is said to be "page-content.json" - which doesn't exist in the file system?

Any help you could provide would be fantastic!

Ok, so got it all working - so far so good! The detailed doco is fantastic Nick!

One strange thing I'm encountering however is that sometimes I get search results back with highlights, other times I don't? Is anyone else encountering this?

Hey all, I've been wracking my brain trying to figure out why I get highlights on some search terms and don't on others... I have a funny feeling the problem is down at the ES level, but am keen to hear if anyone else has encountered this? Thanks so much!!

Nick, who is ElasticSearch guru, is currently holidaying in the USA but I'm sure when he gets back on deck he'll follow up!

Thanks brendo :)

How is your section mapping laid out, specifically symphony_highlight portion for each one?

@nickdunn, the ElasticSearch demo, "Surfin' Shakespeare" is awesome! Unfortunately, I ran into the same problem when re-mapping the sections that @tim.cromwell did. I commented out line #24 and it worked (at least the remapping). Then when I tried to index the sections, both the "Plays" and "Scenes" sections indexed properly. When trying to index the "Speeches", it would freeze my whole computer (MacBook Air, i7, 8GB RAM) and I have to reboot my computer.

Has anyone else run across this problem? If so, can you give me pointers on how to fix this issue.

Also, if I click on the Sessions Logs (under the ElasticSearch menu), I get the following error…

Fatal error: Call to undefined function _() in /Sites/elasticsearch-surfin-shakespeare/extensions/elasticsearch/content/content.sessions.php on line 242

and when I click on Query Logs (under the ElasticSearch menu), I get the following error

Fatal error: Call to undefined function _() in /Sites/elasticsearch-surfin-shakespeare/extensions/elasticsearch/content/content.queries.php on line 241

I am using the Symphony version that came with Nick's demo, Symphony 2.3RC2 and the 0.4.0 version of ElasticSearch extension.

The search field on the frontend is functional, but not all of the results show up in the search (since not all the "Speeches" are indexed).

The errors for Session/Query log should be easily fixed by adding another _, so the function call is __('Text here').

I however know nothing about your other problem :(

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details