I am having the same issue, where when I set build-entry-xml from 'no' to 'yes', I receive the following error...

Fatal error: Class 'extension_subsectionmanager' not found in /Repositories/pcpc/extensions/subsectionmanager/fields/field.subsectionmanager.php on line 696

I am running Symphony 2.3.3 and Subsection Manager 3.5.1

OK. This seems to fix the issue...

Add require_once(EXTENSIONS . '/subsectionmanager/extension.driver.php'); at the top of the class.subsectionmanager.php. Do you know if this would cause issues elsewhere with the Subsection Manager elsewhere?

Guys, I'm having a problem with Elasticsearch, it seems the plugin has been installed and everything is OK, but when I go to Elasticsearch > Mapping on Symphony's admin panel it trows an error that reads Symphony Fatal Error: ElasticSearch "host" not set in configuration., am I missing something regarding configuration? I checked the host name and is set to '', as well as the other params the init function in the ElasticSearch class in class.elasticsearch.php file.

See the attached image.


Have you read through all of the instructions in the readme? See the "Create the index in ElasticSearch" section.

I did it already. The error message is gone but now every item under the "ElasticSearch" submenu shows a blank page.

this is not compatible with latest version of symphony.

Symphony Fatal Error: Call to undefined method Administration::saveConfig() An error occurred in /home/u834900799/public_html/extensions/elasticsearch/extension.driver.php around line 125

will there be an update to this extension?

Hi everyone,

I have a bit of a problem getting my ES install firing on a site I'm working on. I've used ES before and it's worked brilliantly, but this time round I can access the Symphony menu, but not the ElasticSearch menu and get the attached error when I try to do so (I'm on Symphony 2.2.5).

This is the error:

Argument 1 passed to AdministrationPage::__construct() must be an
instance of Administration, none given, called in 
extensions/elasticsearch/lib/class.elasticsearch_administrationpage.php on line 18 and defined

An error occurred in symphony/lib/toolkit/class.administrationpage.php around line 102

Any ideas?

Screen Shot 2014-06-24 at 18.28.44.png

Have you checked out the correct version of the extension? (If you are still using Symphony 2.2.5, you need Version 0.3.1.)

Exactly what I needed after having stared at/worked on this error for too long.

Now I've build my mappings and everything looks swell, thx!

OK, another issue I've been struggling with; My site aggregates articles from a number of other websites every ten minutes.

This means, that the ES mappings need to be constantly updated in order to make the search work as intended.

I've tried calling the Symphony back end re-indexing scripts via the Shell extension, but it doesn't seem to work.

Anyone got a solid solution on how to continuously update the ES server with new entries, maybe through a cron job?

Thanks a bunch, N

Finally got something where I'm able to set up Elastic Search, however I'm having some minor difficulty with the setup. I've created the necessary json and php files and I can see the mappings accordingly. Same as @bzerangue I'm having the mapping asking to be rebuilt.

Rebuild mapping before continuing

I've tried to debug, and I can see that the mapping is being decoded properly, and even the $mapping->send() seems to work as I get the following output once dumped.

object(Elastica_Response)#266 (5) { 
    ["_queryTime":protected]=> NULL 
    ["_responseString":protected]=> string(21) "{"acknowledged":true}" 
    ["_error":protected]=> bool(false)   
    ["_transferInfo":protected]=> array(0) { } 
    ["_response":protected]=> array(1) { ["acknowledged"]=> bool(true) } 

I'm not sure if that shows any error but I think that since the response shows acknowledged it's reaching the local elastic search server. I think the problem could lie with updating the json mappings file with the type, or something similiar. As $type->type is always null in content.mappings.php any help would be appreciated, willing to debug & fix but not sure where I should be looking.

What version of Elasticsearch are you running?

As the extension hasn't been updated in a while, there were changes made to Elasticsearch itself since this extension was built.

Hi John - I noticed Huib picked up a question I asked on twitter, and game with the details. Had installed the last Elasticsearch version. I had some time on my hands so I started updating it. I'm trying to use the official library instead of Elastica so far I've managed to set up the index and get a few documents indexed. Tomorrow I'll have a shot at trying to modify the data sources for search. So maybe there's not too much work left to update the whole extension. If I manage to get it working, I'll ask for some feedback prior to submitting a pull request on the Symphonists repo.

Elastica is complex when there's no need to be. I wrote a system for a site in Elastica, and it never worked as expected and was really hard to debug. Moved over to the official PHP API when it came out, and it is so easy to handle now.

Yep easier to handle, so far moving on quite nicely. Though I think there might be some changes in terms of outputs from the DS - I'm trying to keep it working in the same way. However some underlying things have changed. Facets have been deprecated, whilst aggregations came instead. Most likely I can keep the same XML outputs but not sure weather we should keep the outdated terminology.

I'd update it terminology wise too, keeps it in line with the official Elasticsearch.

When you're ready, do a PR anyway, and I'll take a look myself for testing it.

Will do - there are some small things which still need to amended, but for the most part it should work properly. I haven't done a PR yet not sure if I should do it at this stage or have it throughly tested yet but I've put the changes up on a cloned branch.

John / anyone who's used Elastic Search, does the Sessions page work? and If so what do you currently use? Seems like something's now working when I copied it not sure if I have to update the linked library or if it's something else.

To be honest, the build I was going to do ES for last year died. I've only done a custom build since then, not with Symphony.

I know enough about the API, and Symphony internals to give you some good feedback though.

Ah well it's my first foray into ES, basically there was a page with Session data using browsercap - updated the library and increased memory limit seems to work, pushed updates as well so it should wrap it up I think. I'll give it a try over the weekend and push a PR maybe.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details