I am trying to redirect a bunch of old URLs to my new symphony website:

    ### Redirect blog articles
RedirectMatch ^/index.php/global/article/(.*)$$1

This doesn't really work, however, because Symphony seems to get confused by the index.php bit and keeps adding ?symphony-page= to all the URLs.

It's probably this part that is responsible:

    ### FRONTEND REWRITE - Will ignore files and folders
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*/?)$ index.php?symphony-page=$1&%{QUERY_STRING}    [L]

Can anybody help?

Can you try to add the [L] flag at then end ?

Also, remove your first leading /

RewriteRule ^index.php/global/article/(.*)$$1 [R=301,L]

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details