0 users online. Create an account or sign in to join them.Users

Search

I've been running Symphony for a while now and decided to do some upgrades. I upgraded Symphony from 2.6.2 to 2.7.0, and that worked absolutely perfectly.

I've now just upgraded PHP 5.6 to PHP 7.0, and I'm now unable to log in. I get the following error in manifest/logs/main:

 07 September 2017 3:43 pm > Warning: GenericErrorHandler 2: session_decode(): Session is not active. You cannot decode session data on line 199 of file /var/www/html/symphony/lib/core/class.session.php

Switching between PHP 5.6 and 7.0 confirms the cause; Symphony works perfectly in 5.6 and consistently produces the same error in 7.0. This is a packaged install from the zip file; can anyone steer me to what could be going wrong?

Can you please open an issue for that on our Github repository? Thanks.

I just ran into the exact same error with Symphony 2.6.X and PHP 7.

Did you create an issue on Github that you could point me to?

I couldn't find it there.

The error disappeared in PHP 7.1 for me. If that’s any help.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details