I’ve been setting up some json functionality to my website and I’ve hit a small problem:

When loading a JSON page, symphony is still appending the commented event xml to the end of the page, causing javascript errors when this is loaded

Obviously if I log out of the backend then the problem disappears but I’m still in the debug stages of the site so I need to be logged in, ideally with the event xml still loading on other pages.

Is there anyway of disabling the commented event xml on a page basis? If not how can I disable it sitewide, I couldn’t find the config param.



Just set the value of display_event_xml_in_source to no on config.php

Cheers, thanks for that

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details