0 users online. Create an account or sign in to join them.Users

Search

After upgrading from 2.2.5 to 2.3.1 on my upgrade server, I created a zipped ensemble. I copied the files from the ensemble over the root directory of the server running the 2.2.5 version. Why do I get this error? Is it a permissions thing, caused by a file left over, something else? This is from the http://.../install

Strict Standards: Declaration of MD5::hash() should be compatible with Cryptography::hash($input, $algorithm = 'pbkdf2') in /var/www/snet/symphony/lib/toolkit/cryptography/class.md5.php on line 54

Strict Standards: Declaration of MD5::compare() should be compatible with Cryptography::compare($input, $hash, $isHash = false) in /var/www/snet/symphony/lib/toolkit/cryptography/class.md5.php on line 54

Strict Standards: Declaration of SHA1::hash() should be compatible with Cryptography::hash($input, $algorithm = 'pbkdf2') in /var/www/snet/symphony/lib/toolkit/cryptography/class.sha1.php on line 53

Strict Standards: Declaration of SHA1::compare() should be compatible with Cryptography::compare($input, $hash, $isHash = false) in /var/www/snet/symphony/lib/toolkit/cryptography/class.sha1.php on line 53

Strict Standards: Declaration of PBKDF2::compare() should be compatible with Cryptography::compare($input, $hash, $isHash = false) in /var/www/snet/symphony/lib/toolkit/cryptography/class.pbkdf2.php on line 170

Strict Standards: Declaration of UpdaterPage::build() should be compatible with HTMLPage::build() in /var/www/snet/install/lib/class.updaterpage.php on line 131

Strict Standards: Static function Migration::run() should not be abstract in /var/www/snet/install/lib/class.migration.php on line 31

Strict Standards: Static function Migration::getVersion() should not be abstract in /var/www/snet/install/lib/class.migration.php on line 40

Strict Standards: Static function Migration::getReleaseNotes() should not be abstract in /var/www/snet/install/lib/class.migration.php on line 49

Strict Standards: Declaration of Updater::initialiseLog() should be compatible with Symphony::initialiseLog($filename = NULL) in /var/www/snet/install/lib/class.updater.php on line 9

Strict Standards: Declaration of Updater::initialiseConfiguration() should be compatible with Symphony::initialiseConfiguration(array $data = Array) in /var/www/snet/install/lib/class.updater.php on line 9

Symphony Strict Notice: Only variables should be passed by reference

An error occurred in /var/www/snet/install/lib/class.updaterpage.php around line 30
    25                     : Symphony::Configuration()->get('version', 'symphony')
    26             );
    27
    28             // Add Release Notes for the latest migration
    29             if(isset($this->_params['release-notes'])){
    30                 $h1 = end($this->Form->getChildrenByName('h1'));
    31                 if($h1 instanceof XMLElement) {
    32                     $h1->appendChild(
    33                         new XMLElement(
    34                             'em', 
Backtrace
    [/var/www/snet/install/lib/class.updaterpage.php:30]
        GenericErrorHandler::handler();
    [/var/www/snet/symphony/lib/toolkit/class.htmlpage.php:87]
        UpdaterPage->__build();
    [/var/www/snet/install/lib/class.installerpage.php:39]
        HTMLPage->generate();
    [/var/www/snet/install/lib/class.installer.php:642]
        InstallerPage->generate();
    [/var/www/snet/install/lib/class.updater.php:140]
        Installer::__render();
    [/var/www/snet/install/index.php:79]
        Updater->run();
Database Query Log
    [0.0004] SET character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8';
    [0.0002] SET CHARACTER SET 'utf8'; 

Do you have PHP 5.4 on your server?

Please disregard the error posted for this topic. Refer to the Export Ensemble extension documentation. It is very complete in order to create an Ensemble. To install the Ensemble, I think I'm correct if you clear the root directory, copy the files from the zip created, set the appropriate permissions per the install ('chmod 777 symphony .' and 'chmod -R 777 workspace'), create an instance in the database per install, go to http://yourwebsite/install, and follow the instructions. The install directory is required for a complete ensemble and can be obtained by allowing permissions and using the Export Ensemble extension or downloading from the website or git. In other words create the ensemble complete with install directory or add the install directory.

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.1
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details