Hello, Symphony community! Why do i cannot login to Symphony CMS Admin zone using MS Internet Explorer? I just type username and password, click login button, and have no result. It refreshes and i again see login page without any messages... Btw, if i use wrong user/pass pair, Symphony told to me: "The supplied password was rejected." So, does anybody know, what should i do to get logged on using MS IE? Thanks for your answer!

P.S. Symphony 2.1.2

I never experienced that. And you are able to login using a different browser?

Yes, i've just try to login with Opera - and it works! Also i've try it with FireFox... and it was fault... So IE and FF does not provides to me admin zone... And Opera do!.. hmm...

For now i have tried to be logged on with Chrome browser... And it was bad try again... =(((

Is is possible that you updated your install just recently? The password encryption changed in Symphony 2.1, so maybe this is the cause of your problems. Have you tried reseting your password?

Nils, no, i think it will not break the trouble, because Opera works fine. It means, that password encryption works as it should, i think. Am i wrong?

But now i'm installing 2.2. When it'll be done i'll write fix it my truoble or not.

It means, that password encryption works as it should, i think. Am i wrong?

I'm not sure about that. As long as you've got a valid cookie everything should be fine I guess.

Nils, thanks for discussion. I've deleted all of cookies from Chrome, but there is no effect... It still can't provide me an admin zone, even in version 2.2 via Chrome, IE and FF, except Opera. ;( And admin zone (v 2.2) in Opera looks very... ugly :(


This can't be right... What did you do to your Opera? :-)

Because other people (including me) are successfully using Fx and Chrome I guess it has more to do with your Server setup.

Edit: Never mind. Should have read the discussion first.

I've solved this problem! I'm using at my workplace WinXP with locally running Apache+php+MySQL. So, my Symphony test project running on local PC named "snail" (i't s really sanily-speed PC). And getDomain() in class.session.php returns "snail". BUT other than Opera browsers seems are using incorrect working WinAPI (at WinXP it is) to resolve domain names, and resolves my test site only as "localhost". Yep, here is the problem! So, if i change line 92 in "/lib/core/class.session.php"

session_set_cookie_params($lifetime, $path, ($domain ? $domain : self::getDomain()), false, $httpOnly);


session_set_cookie_params($lifetime, $path, 'localhost', false, $httpOnly);

than authentication begins to work correct. Note, that i was using "http://snail/symphony" address to get to admin zone. If it has been the "http://localhost/symphony" it should works fine from begin (but i've not checked this - it's just conclusion by viewing the getDomain() function source code).

BUT! There is one more correct fix: just comment this line! So, with this line commented project will work with any host - "snail" or "localhost" - does not matter.

That's really weird. Do you have a Vista- or Win7-computer around to test if they have this problem too?

Wich method are you using to resolve snail? An on-site DNS server, ARP or the hosts file? Back in the Windows-days I was always using the hosts file and didn't have any problems.

i'll be able to test this problem on win2008r2 server in few days. Possibly tomorrow.

On this PC with WinXP name "snail" set only as PC-name, so, it resolves via netbios.

Hello, I have the same issue (hostname without domain name doesn't work)

  • URL: http://symphonycms1/symphony
  • fresh install symphony-2.2.5
  • server Ubuntu 12.04 Beta
  • Desktop: OSX 10.6.8
  • Browser : Google Chrome 17.0.963.66

  • Safari is OK (v 5.1.2 (6534.52.7))

  • Firefox OK (v 10.0)

I can login with Chrome changing URL to http://symphonycms1.localdomain/symphony

Hello again,

the problem seems to come from the getDomain() method in class.session.php I've read the following RFCs :, obsoleted by, obsoleted by

I don't understand why you are treating 'localhost' as a special case, and in my case (host-only server name), I would set the domain to NULL (

If the server omits the Domain attribute, the user agent will return the cookie only to the origin server.the cookie only to the origin server.

I'm having what appears to be a similar issue with Symphony 2.3.1 to which I've upgraded from 2.2.5. I have not been able to login to a project on Mac OS 10.8.3 on any of the following browsers:

  • Safari
  • Chrome
  • Firefox
  • Opera

I'm looking into the localhost solution in comment #11.

Per Can't get to admin area, I can confirm that my .htaccess is for 2.3.x.

I'd also add that when I login with a known INCORRECT password I receive the normal Symphony error notification, "The login details provided are incorrect." However, when I enter the known CORRECT password, the form posts, gives no feedback, and does not login or redirect.

Further, the hash in the password field (table: sym_authors) is changed upon entering the known CORRECT password to PBKDF2v1|10000|29846548654be8d15328|zCZ+. I know we're using salt now, but this doesn't look salted though it is SHA-1 length (40 char).

Any help you can give is greatly appreciated.

c.f. StackOverflow thread

The /lib/core/class.session.php file is as it should be per this comment.

Have you tried to change localhost to to see if a qualified IP would work?

@Moonoo2 thank you for the reply.

Here's the entry in my host file:

## Default Settings       localhost

Per @bzerangue here's my .htaccess file contents:

Create an account or sign in to comment.

Symphony • Open Source XSLT CMS

Server Requirements

  • PHP 5.3-5.6 or 7.0-7.3
  • PHP's LibXML module, with the XSLT extension enabled (--with-xsl)
  • MySQL 5.5 or above
  • An Apache or Litespeed webserver
  • Apache's mod_rewrite module or equivalent

Compatible Hosts

Sign in

Login details